Giter Site home page Giter Site logo

gllock.nix's Introduction

gllock.nix

Nix derivation and NixOS module for gllock.

Usage

Add the following to your configuration.nix

{ ... }: {
  imports = [
    (import (builtins.fetchTarball {
      url =
        "https://github.com/jmackie/gllock.nix/archive/8965b8f904f77f7cfc9e0666284abd729faff752.tar.gz";
      sha256 = "1hcz4a6qb7k5gd2h09i5ac32z7mfnjjm76kv7xf1bahvh19h8mxb";
    }) { shader = "circle"; })
  ];
}

(you'll probably want to update the rev and sha256)

Testing

nix-build -E '(import <nixpkgs> {}).callPackage ./gllock.nix { shader = "circle"; }'

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.