Giter Site home page Giter Site logo

jlu-drcom-client.nix's Introduction

jlu-drcom-client.nix

Net Authentication Client for JiLin University as a NixOS module.

ported from github:AndrewLawrence80/jlu-drcom-client.

Usage

for Flakes users

{
    inputs = {
        drcom.url = "github:misaka18931/jlu-drcom-client.nix";
        drcom.inputs.nixpkgs.follows = "nixpkgs";
        ...
    };
    outputs = { drcom, ... }:
    {
        nixosConfigurations."yourHostname" = nixpkgs.lib.nixosSystem {
            modules = [
                drcom.nixosModules.default
                {
                    enable = true;
                    configFile = "/path/to/config";
                }
            ];
            ...
        };
    }
}

for non-Flake users

not tested yet.

Configuration

Credentials are passed to the program by systemd's EnvironmentFile.

# path/to/config
JLU_USERNAME=your username at mails.jlu.edu.cn
JLU_PASSWD=your passwd for mails.jlu.edu.cn
JLU_IPADDR=your ip address assigned (found in ip.jlu.edu.cn)
JLU_HWADDR=your MAC address registered in ip.jlu.edu.cn

DO NOT put your plaintext credentials directly into services.jlu-drcom-client.configFile, as they will end up in the world readable /nix/store. Instead, use a secret management scheme like sops-nix.

Thanks @AndrewLawrence80 for amazing repository.

jlu-drcom-client.nix's People

Contributors

misaka18931 avatar andrewlawrence80 avatar

Stargazers

 avatar

Watchers

 avatar

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.